Scheduler weekly MS

From Chime Master Help
Revision as of 17:53, 24 September 2015 by Rickwhite (talk | contribs) (created)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Suite-5-10-week-tslvl.png This is a view of the graphical editor for time strike and outside level scheduling on a weekly basis.

With the scheduler, you can view, edit, and save multiple weekly schedules to your personal computer. A schedule can be loaded into your carillon unit at any time.

The text editing modes are useful for programming non-time strike events such as music and liturgical ringing such as Angelus and call to worship bells. The Time Strikes/Auto Levels modes are the best way to program time striking and set the playing volume for certain times of the day.

On the main Management Suite menu, click the Scheduler button to open this application. A standard menu bar is located at the top of the window. Use the File menu to open and save schedules to your hard drive. Use the Edit menu to open additional panels for schedule editing and the Device menu to transfer data between the PC and the carillon. Data transfer can only be accomplished when the carillon is connected to your computer via the USB interface. Toolbar buttons can be used instead of the pull-down menus.

File:Suite-week-toolbar.png

Review the weekly schedule

To open and view a schedule,

  1. Select New Schedule from the file menu for a blank schedule, or
  2. Select Open from the file menu to review a previously saved schedule, or
  3. Select Get Schedule from Device from the Device menu to see the current schedule.

Filter the Schedule Listing

Click the right mouse button in the empty space of the schedule to set filtering options to view all time slots, slots with time-strike options, or times with other events programmed.

Suite-5-10-week-edit.png

The schedule window lists the day, time slot, programmable volume level, time strike mode, and selections for each quarter-hour of the week. Multiple schedules can be open at a time in the tabbed window-viewing environment. It is a good idea to name and save your file when starting a new schedule and to save often.

Creating and Editing Weekly Schedules

The schedule data is predominant in the Scheduler window and is used to select certain timeslots or view the current schedule file. It is important to remember that the schedule you are working on is not loaded and active in the carillon’s schedule memory until it is put there. Keep in mind that someone else may have edited the schedule on the carillon since the last Scheduler file was uploaded into it.

A good habit to get into might be to get the active schedule from the carillon and save it as “backup-(today’s date)” before making changes to it.

Selections

You will notice four sets of “0000” for every quarter-hour under Selections in a new schedule listing. These are fields that hold selections for anything other than time strike programs. If you are entering a specific song or bell ringing operation, the selection number is entered directly into the selection field. You can also copy and paste the selection number using Ctrl-C and Ctrl-V.

If you don’t want to begin ringing on the quarter-hour, a pause macro can be programmed to delay the beginning of the program. Pause macro codes are on the pull-down menu in each selection field. For example if you want to ring a swinging bell at 8:55, program an eight-minute and then a two-minute pause before the ringing code in the 8:45 time slot. To erase a selection in the text edit mode, choose the blank selection from the pull-down menu, or enter four zeros. The following Random Group tables show two different ways to program random music. You can directly enter a Grpn selection (using the pull-down menu) for each random song, or choose a 70xy block macro code to play multiple musical selections in one selection slot. Since the numeric macro codes define how a performance ends, selections placed to the right of them will not play in the automatic schedule.

Editing Selections

Click the Edit Selections tool bar button or select it from the Edit menu. A window will open with a panel that allows you to change one time slot. Tabs at the top of the window allow you to select other methods of setting the time so that you can program multiple days, a range of time or only those time slots that you have selected in the schedule-viewing window.

Although you can program changes to the time striking and volume levels in the Edit Selections panels, it is easier to do that in the Edit Time Strikes/Auto Levels mode described below. When you open a text mode editing panel the check boxes for level and time strike changes are unchecked to prevent unintended changes. Selections may be programmed in the lower portion of the Edit Selections panels. Up to four selections can be entered per time slot from left to right. To enter a numeric selection, click your mouse in the selection window and then type the four-digit selection number. The cursor will advance to the next selection window after you make the entry. To program macro codes for pauses and random music groups use the drop down button next to the selection window, and select the code.

To erase selections you have entered, use the pull down button to select a blank entry. You should do this from right to left because the editing panel does not allow blank selections between programmed selections.